[Tizen-submit] 15917: Changes to Tizen:IVI/setup-efi-ivi

noreply at tizen.org noreply at tizen.org
Fri Oct 11 14:17:32 GMT 2013


Hi,
Artem Bityutskiy have made the following changes to setup-efi-ivi in project Tizen:IVI. Please review and accept ASAP.

Thank You,

[This message was auto-generated]

---

Request: #15917

  submit:       Tizen:IVI:build/setup-efi-ivi(cleanup) -> Tizen:IVI


Message:
Submitter: Artem Bityutskiy <artem.bityutskiy at linux.intel.com>
Comments: Do not add .conf suffix to the default entry in loader.conf file
Git project: profile/ivi/setup-efi-ivi
Tag: submit/tizen/20131011.141814
Commit: 9726610bd709d53df6d0cd2b7b0f5642932779ea packaging: release out (correct loader.conf)

State:   new        2013-10-11T14:16:06 tizenrobot
Comment: <no comment>
changes files:
--------------
--- setup-efi-ivi.changes
+++ setup-efi-ivi.changes
@@ -0,0 +1,5 @@
+* Fri Oct 11 2013 Artem Bityutskiy <artem.bityutskiy at linux.intel.com> 1.0
+- The default entry in the 'loader.conf' file should not have the '.conf'
+  suffix, but 'setup-efi-ivi' added it, so gummiboot always ignored our default
+  entry. Fix this issue.
+

spec files:
-----------
--- setup-efi-ivi.spec
+++ setup-efi-ivi.spec
@@ -1,7 +1,7 @@
 Name:           setup-efi-ivi
 Version:        1.0
-Release:        8
-VCS:            profile/ivi/setup-efi-ivi#submit/tizen/20130930.055640-0-g0b616d8802d372c97b774bfbf4ea269d107434f4
+Release:        9
+VCS:            profile/ivi/setup-efi-ivi#submit/tizen/20131011.141814-0-g9726610bd709d53df6d0cd2b7b0f5642932779ea
 License:        GPL-2.0
 Summary:        System UEFI boot setup
 Url:            http://www.tizen.org

other changes:
--------------

++++++ setup-efi-ivi_1.0.tar.gz
--- packaging/setup-efi-ivi.changes
+++ packaging/setup-efi-ivi.changes
@@ -1,3 +1,8 @@
+* Fri Oct 11 2013 Artem Bityutskiy <artem.bityutskiy at linux.intel.com> 1.0
+- The default entry in the 'loader.conf' file should not have the '.conf'
+  suffix, but 'setup-efi-ivi' added it, so gummiboot always ignored our default
+  entry. Fix this issue.
+
 * Mon Sep 30 2013 Artem Bityutskiy <artem.bityutskiy at linux.intel.com> 1.0
 - Use mount prefix when searching for the gummiboot MBR binaries.
 
--- packaging/setup-efi-ivi.spec
+++ packaging/setup-efi-ivi.spec
@@ -1,6 +1,6 @@
 Name:           setup-efi-ivi
 Version:        1.0
-Release:        8
+Release:        9
 License:        GPL-2.0
 Summary:        System UEFI boot setup
 Url:            http://www.tizen.org
--- setup-efi-ivi
+++ setup-efi-ivi
@@ -78,7 +78,7 @@
 
 cat > "$esp/loader/loader.conf" <<-EOF
 timeout 0
-default $newest_kernel.conf
+default $newest_kernel
 EOF
 
 # Create a gummiboot entry for each kernel
--- setup-gummiboot-conf
+++ setup-gummiboot-conf
@@ -62,7 +62,7 @@
 	fatal "no gummiboot entries found in \"$entries_dir\""
 
 # Get the default entry name
-default_entry="$(cat "$conf_file" | sed -n -e 's/[ \t]*default[ \t]\+\(.\+\)[ \t]*/\1/p')"
+default_entry="$(cat "$conf_file" | sed -n -e 's/[ \t]*default[ \t]\+\(.\+\)[ \t]*/\1.conf/p')"
 [ -n "$default_entry" ] || \
 	fatal "cannot find the default entry in \"$conf_file\""
 [ "$(printf "%s\n" "$default_entry" | wc -l)" -eq "1" ] || \


More information about the Tizen-submit mailing list