[Tizen-submit] 15927: Changes to Tizen/hplip

noreply at tizen.org noreply at tizen.org
Mon Oct 14 01:45:43 GMT 2013


Hi,
GangHeok Kim have made the following changes to hplip in project Tizen. Please review and accept ASAP.

Thank You,

[This message was auto-generated]

---

Request: #15927

  submit:       Tizen:build/hplip(cleanup) -> Tizen


Message:
Submitter: GangHeok Kim <gangheok.kim at samsung.com>
Comments: Fixed build error by libjpeg-turbo buildrequires
Git project: platform/upstream/hplip
Tag: submit/tizen/20131014.014559
Commit: f8390c646df3b138658a1b9526aa79096785b932 Fixed build error by changing buildrequires from pkgconfig(turbo-jpeg) to libjpeg-devel

State:   new        2013-10-14T01:44:07 tizenrobot
Comment: <no comment>
changes files:
--------------

++++++ new changes file:
--- hplip.changes
+++ hplip.changes
@@ -0,0 +1,5 @@
+* Sun Aug 25 2013 Chengwei Yang <chengwei.yang at intel.com> accepted/tizen/20130520.101756 at 6545488
+- merge with master
+- Tizen 2.1 base
+- Initial empty repository
+

new:
----
  hplip.changes

spec files:
-----------
--- hplip.spec
+++ hplip.spec
@@ -26,7 +26,7 @@
 # Official releases have a 3 digit number and release candidates have a 4 digit number: x.y.m.rc
 Version:        3.12.4
 Release:        13
-VCS:            platform/upstream/hplip#submit/tizen/20130517.050251-0-g6545488
+VCS:            platform/upstream/hplip#submit/tizen/20131014.014559-0-gf8390c646df3b138658a1b9526aa79096785b932
 Url:            http://hplipopensource.com
 # Source0...Source9 is for sources from HP:
 # URL for Source0: http://prdownloads.sourceforge.net/hplip/hplip-3.12.4.tar.gz
@@ -49,7 +49,7 @@
 #BuildRequires:  hicolor-icon-theme
 #BuildRequires:  libdrm-devel
 #BuildRequires:  libgphoto2-devel
-BuildRequires:  pkgconfig(turbojpeg)
+BuildRequires:  libjpeg-devel
 #BuildRequires:  libqt4-devel
 BuildRequires:  libtool
 BuildRequires:  pkgconfig(libusb)
@@ -211,108 +211,6 @@
 
 /usr/share/doc/packages/hplip/index.html
 
-
-#%package hpijs
-#Summary:        Only plain printing with HPLIP printer drivers
-#Group:          Hardware/Printing
-# Since Nov 14 2007 ghostscript-library does no longer require /usr/bin/hpijs
-# but only "Suggests hplip-hpijs" (see Novell/Suse Bugzilla bnc#341564).
-# Have the matching "reverse suggests" = "Enhances" here
-# to document the ghostscript <-> hplip-hpijs relationship:
-#Enhances:       ghostscript
-# On a minimalist system only hplip-hpijs may be installed
-# or on a minimalist package repository (e.g. on the openSUSE CDs)
-# only hplip-hpijs may be available (even when a usual system is installed).
-# When only hplip-hpijs is there, it should tell the dependency resolver
-# that for usual functionality, hplip should be installed too (if possible).
-# Unfortunately the installer ignores suggested packages silently
-# but on the other hand I cannot use "Recommends hplip" here
-# because the installer installs recommended packages silently
-# which would bloat a minimal selection (when hplip is available to be installed)
-# because the minimal selection contains hplip-hpijs which recommends hplip
-# so that the installer installs hplip and all what this requires silently
-# see https://bugzilla.novell.com/show_bug.cgi?id=546893
-# Require only the matching version of the hplip main-package
-# (compare the "Requires: hplip-hpijs" entry above) but do not depend
-# on the exact matching release because the exact matching release
-# may be not available to be installed (e.g. when hplip-hpijs-1.2.3-4.5 is
-# installed from the openSUSE CDs but on our official online repository
-# only hplip-1.2.3-6.7 is available which should usually also work):
-#Suggests:       %{name} = %{version}
-# hpijs-standalone was a stand-alone minimalist package
-# which is no longer provided since a long time.
-# hplip-hpijs and hpijs-standalone both contain /usr/bin/hpijs
-# so that both packages have a RPM conflict which should
-# be solved by a silent replacement of the old hpijs-standalone.
-# This Obsoletes is intentionally unversioned because
-# hplip-hpijs should replace any version of hpijs-standalone.
-#Obsoletes:      hpijs-standalone
-# Either the hplip17 packages or the hplip packages can be installed,
-# see https://bugzilla.novell.com/show_bug.cgi?id=251830#c20
-# for the full story why there is this unversioned Obsoletes:
-#Obsoletes:      hplip17-hpijs
-# Obsolete the hplip3 copy that was introduced for older SLED11-GA HP preloads:
-#Provides:       hplip3-hpijs = 3.9.5
-#Obsoletes:      hplip3-hpijs < 3.9.5

Please refer to OBS webUI for more details about this SR.


More information about the Tizen-submit mailing list