[Tizen-submit] 20911: Changes to Tizen:Generic/gst-plugins-bad

noreply at tizen.org noreply at tizen.org
Sat Feb 8 08:22:39 GMT 2014


Hi,
Yan Yin have made the following changes to gst-plugins-bad in project Tizen:Generic. Please review and accept ASAP.

Thank You,

[This message was auto-generated]

---

Request: #20911

  submit:       Tizen:Generic:build/gst-plugins-bad(cleanup) -> Tizen:Generic


Message:
Submitter: Yan Yin <yan.yin at intel.com>
Comments: packaging: support non X11 configuration (wayland)
Git project: platform/upstream/gst-plugins-bad
Tag: submit/tizen/20140208.082502
Commit: 107b29dc0d80485edbec155fbe4eb208341d3827 packaging: support non X11 configuration (wayland)

State:   new        2014-02-08T08:24:32 tizenrobot
Comment: <no comment>
changes files:
--------------

++++++ new changes file:
--- gst-plugins-bad.changes
+++ gst-plugins-bad.changes
@@ -0,0 +1,9 @@
+* Tue Jun 18 2013 Anas Nashif <anas.nashif at intel.com> 1.0.7 at 0b1d2ae
+- Update to 1.0.7
+
+* Wed Jan 23 2013 Anas Nashif <anas.nashif at intel.com> upstream/1.0.5 at d7d49f2
+- update to 1.0.5
+
+* Sat Dec 15 2012 Anas Nashif <anas.nashif at intel.com> upstream/1.0.2 at ac677cd
+- initial packaging
+

++++++ deleted changes files:
--- _service:gbs:gst-plugins-bad.changes

old:
----
  _service
  _service:gbs:0001-check-for-libva-instead-of-ffmpeg.patch
  _service:gbs:gst-plugins-bad-1.0.7.tar.xz
  _service:gbs:gst-plugins-bad.changes
  _service:gbs:gst-plugins-bad.manifest
  _service:gbs:gst-plugins-bad.spec

new:
----
  27ae6ba-to-0865d9a.diff
  gst-plugins-bad-1.0.7.tar.xz
  gst-plugins-bad.changes
  gst-plugins-bad.manifest
  gst-plugins-bad.spec

spec files:
-----------

++++++ new spec file:
--- gst-plugins-bad.spec
+++ gst-plugins-bad.spec
@@ -0,0 +1,281 @@
+%bcond_with wayland
+%bcond_with x
+
+Name:           gst-plugins-bad
+VCS:            platform/upstream/gst-plugins-bad#107b29dc0d80485edbec155fbe4eb208341d3827
+Version:        1.0.7
+Release:        0
+%define gst_branch 1.0
+Summary:        GStreamer Streaming-Media Framework Plug-Ins
+License:        GPL-2.0+ and LGPL-2.1+
+Group:          Multimedia/Audio
+Url:            http://gstreamer.freedesktop.org/
+Source:         http://gstreamer.freedesktop.org/src/gst-plugins-bad/%{name}-%{version}.tar.xz
+Source1001: 	gst-plugins-bad.manifest
+# Patches auto-generated by git-buildpackage:
+Patch0:         27ae6ba-to-0865d9a.diff
+BuildRequires:  gst-common
+BuildRequires:  gettext-tools
+BuildRequires:  SDL-devel
+BuildRequires:  autoconf
+BuildRequires:  gcc-c++
+BuildRequires:  glib2-devel >= 2.31.14
+BuildRequires:  gstreamer-devel >= 1.0.0
+BuildRequires:  gst-plugins-base-devel >= 1.0.0
+BuildRequires:  pkgconfig(orc-0.4) >= 0.4.11
+BuildRequires:  python
+BuildRequires:  xsltproc
+BuildRequires:  pkgconfig(cairo)
+BuildRequires:  pkgconfig(gio-2.0) >= 2.25.0
+BuildRequires:  pkgconfig(libcrypto)
+BuildRequires:  pkgconfig(libcurl) >= 7.21.0
+BuildRequires:  pkgconfig(libexif) >= 0.6.16
+BuildRequires:  pkgconfig(libpng) >= 1.2
+BuildRequires:  pkgconfig(openssl) >= 0.9.5
+BuildRequires:  pkgconfig(sndfile) >= 1.0.16
+%if %{with wayland}
+BuildRequires:  pkgconfig(wayland-client) >= 1.0.0
+%endif
+%if %{with x}
+BuildRequires:  pkgconfig(x11)
+%endif
+Requires(post): glib2-tools

Please refer to OBS webUI for more details about this SR.


More information about the Tizen-submit mailing list