[Tizen-submit] 21362: Changes to Tizen:Mobile/gst-plugins-good

noreply at tizen.org noreply at tizen.org
Mon Feb 17 03:11:15 GMT 2014


Hi,
Yan Yin have made the following changes to gst-plugins-good in project Tizen:Mobile. Please review and accept ASAP.

Thank You,

[This message was auto-generated]

---

Request: #21362

  submit:       Tizen:Mobile:build/gst-plugins-good(cleanup) -> Tizen:Mobile


Message:
Submitter: Yan Yin <yan.yin at intel.com>
Comments: upgrading to 1.2
Git project: platform/upstream/gst-plugins-good
Tag: submit/tizen/20140217.031130
Commit: adaf2c51447443e956b1fec00e3e7caa90c4ba67 packaging: handle X dependencies as option.

State:   new        2014-02-17T03:10:53 tizenrobot
Comment: <no comment>
changes files:
--------------
--- gst-plugins-good.changes
+++ gst-plugins-good.changes
@@ -0,0 +1,5 @@
+* Tue Aug 13 2013 Philippe Coval <philippe.coval at eurogiciel.fr> submit/tizen/20130812.031142 at 2fbbbf0
+- packaging: adding libv4l2
+  Bug-Tizen: TZPC-3648 (gst is not built with v4l support)
+- pngdec: Implement parsing functionality
+

old:
----
  0001-Make-pulsesink-autostart-pulseaudio-if-needed.patch
  0002-pngdec-Implement-parsing-functionality.patch
  gst-plugins-good-1.0.7.tar.xz

new:
----
  0001-add-packaging-files.patch
  0002-Make-pulsesink-autostart-pulseaudio-if-needed.patch
  common.tar.bz2
  gitmodules.sh
  gst-plugins-good-1.2.0.tar.xz

spec files:
-----------
--- gst-plugins-good.spec
+++ gst-plugins-good.spec
@@ -1,18 +1,20 @@
+%bcond_with x
+
 Name:           gst-plugins-good
-Version:        1.0.7
+VCS:            platform/upstream/gst-plugins-good#adaf2c51447443e956b1fec00e3e7caa90c4ba67
+Version:        1.2.0
 Release:        0
-VCS:            platform/upstream/gst-plugins-good#accepted/tizen/20130912.100508-0-g2fbbbf0d048ed384a340de3512d32d890090b7e2
 License:        LGPL-2.1+
 %define gst_branch 1.0
 Summary:        GStreamer Streaming-Media Framework Plug-Ins
 Url:            http://gstreamer.freedesktop.org/
 Group:          Multimedia/Audio
 Source0:        http://download.gnome.org/sources/gst-plugins-good/1.0/%{name}-%{version}.tar.xz
+Source100:      common.tar.bz2
 Source1001: 	gst-plugins-good.manifest
 # Patches auto-generated by git-buildpackage:
-Patch0:         0001-Make-pulsesink-autostart-pulseaudio-if-needed.patch
-Patch1:         0002-pngdec-Implement-parsing-functionality.patch
-BuildRequires:  gst-common
+Patch0:         0001-add-packaging-files.patch
+Patch1:         0002-Make-pulsesink-autostart-pulseaudio-if-needed.patch
 BuildRequires:  gcc-c++
 BuildRequires:  gettext-tools
 BuildRequires:  glib2-devel >= 2.31.14
@@ -28,19 +30,22 @@
 BuildRequires:  pkgconfig(gdk-pixbuf-2.0) >= 2.8.0
 BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0) >= 1.0.2
 BuildRequires:  pkgconfig(gudev-1.0) >= 143
-BuildRequires:  pkgconfig(ice)
 BuildRequires:  pkgconfig(libpng) >= 1.2
 BuildRequires:  pkgconfig(libpulse) >= 1.0
 BuildRequires:  pkgconfig(libsoup-2.4)
 BuildRequires:  pkgconfig(libxml-2.0) >= 2.4.9
-BuildRequires:  pkgconfig(sm)
 BuildRequires:  pkgconfig(speex) >= 1.1.6
 BuildRequires:  pkgconfig(vpx) >= 1.1.0
+# TODO find where process.h comes from, not kernel-devel and not wxWidgets so far.
+%if %{with x}
+BuildRequires:  pkgconfig(ice)
+BuildRequires:  pkgconfig(sm)
 BuildRequires:  pkgconfig(xdamage)
 BuildRequires:  pkgconfig(xfixes)
 # used by libgstvideo4linux2.so
 BuildRequires:  pkgconfig(xv)
-# TODO find where process.h comes from, not kernel-devel and not wxWidgets so far.
+%endif
+
 BuildRequires:  pkgconfig(zlib)
 BuildRequires:  pkgconfig(libv4l2)
 Requires:       gst-plugins-base >= 1.0.0
@@ -66,14 +71,12 @@
 %prep
 chmod 0644 %{SOURCE0}
 %setup -q
-# 0001-Make-pulsesink-autostart-pulseaudio-if-needed.patch

Please refer to OBS webUI for more details about this SR.


More information about the Tizen-submit mailing list