[Tizen-submit] 42634: Changes to Tizen:IVI:Panda/tel-plugin-dbus_tapi

noreply at tizen.org noreply at tizen.org
Thu Sep 3 02:18:37 GMT 2015


Hi,
Wootak Jung have made the following changes to tel-plugin-dbus_tapi in project Tizen:IVI:Panda. Please review and accept ASAP.

Thank You,

[This message was auto-generated]

---

Request: #42634

  submit:       Tizen:IVI:Panda:build/tel-plugin-dbus_tapi at 7(cleanup) -> Tizen:IVI:Panda


Message:
Submitter: Wootak Jung <wootak.jung at samsung.com>
Comments: Sync from SPIN branch
Git project: platform/core/telephony/tel-plugin-dbus_tapi
Tag: submit/tizen/20150903.021205
Commit: b3c6807af55c9e9a22d2b66af96bee42a5611d56 Sync from SPIN branch

State:   new        2015-09-03T02:18:12 tizenrobot
Comment: <no comment>
old:
----
  _aggregate
  tel-plugin-dbus_tapi-0.1.218.tar.gz
  tel-plugin-dbus_tapi.manifest
  tel-plugin-dbus_tapi.spec

new:
----
  _service
  _service:gbs:_git-meta
  _service:gbs:tel-plugin-dbus_tapi-0.3.64.tar.gz
  _service:gbs:tel-plugin-dbus_tapi.spec

spec files:
-----------

++++++ new spec file:
--- _service:gbs:tel-plugin-dbus_tapi.spec
+++ _service:gbs:tel-plugin-dbus_tapi.spec
@@ -0,0 +1,61 @@
+%define major 0
+%define minor 3
+%define patchlevel 64
+
+Name:           tel-plugin-dbus_tapi
+VCS:            platform/core/telephony/tel-plugin-dbus_tapi#b3c6807af55c9e9a22d2b66af96bee42a5611d56
+Version:        %{major}.%{minor}.%{patchlevel}
+Release:        2
+License:        Apache-2.0
+Summary:        dbus-tapi plugin for telephony
+Group:          System/Libraries
+Source0:        tel-plugin-dbus_tapi-%{version}.tar.gz
+BuildRequires:  cmake
+BuildRequires:  python-xml
+BuildRequires:  python
+BuildRequires:  pkgconfig(appsvc)
+BuildRequires:  pkgconfig(capi-appfw-app-manager)
+BuildRequires:  pkgconfig(aul)
+BuildRequires:  pkgconfig(gio-2.0)
+BuildRequires:  pkgconfig(gio-unix-2.0)
+BuildRequires:  pkgconfig(glib-2.0)
+BuildRequires:  pkgconfig(libxml-2.0)
+BuildRequires:  pkgconfig(tcore)
+BuildRequires:  pkgconfig(cynara-client)
+BuildRequires:  pkgconfig(cynara-creds-gdbus)
+BuildRequires:  pkgconfig(cynara-session)
+
+
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+
+%description
+dbus-tapi plugin for telephony
+
+%prep
+%setup -q
+
+%build
+versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
+
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+	-DLIB_INSTALL_DIR=%{_libdir} \
+	-DVERSION=$versionint \
+	-DSYSCONFDIR=%{_sysconfdir}
+
+make %{?_smp_mflags}
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%install
+%make_install
+mkdir -p %{buildroot}%{_datadir}/license
+
+%files
+%manifest tel-plugin-dbus_tapi.manifest
+%defattr(644,system,system,-)
+#%doc COPYING
+%{_libdir}/telephony/plugins/*
+%{_datadir}/license/tel-plugin-dbus_tapi

++++++ deleted spec files:
--- tel-plugin-dbus_tapi.spec


Please refer to OBS webUI for more details about this SR.


More information about the Tizen-submit mailing list